Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000996Documentation, Examples, and Web SiteWriting with Informpublic2012-08-19 19:272014-05-07 07:38
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityN/A
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000996: WI 22.7 says that sounds are only supported under Glulx, though they are accepted for the Z machine
DescriptionWI 22.7 reads

- - - -
Once again, only Glulx-based works can incorporate sound effects...
- - - -

but Inform seems to support sound under version 6 of the Z-machine; the intermediate I6 has

- - - -
[ VM_SoundEffect resource_ID;
    #IFTRUE #version_number == 6; ! Z-machine version 6
    @sound_effect resource_ID;
    #ENDIF;
];
- - - -

and sound declarations and the play phrase are accepted when compiling to Z, as demonstrated in the attached source.
Minimal Source Text To Reproduce
There is a room.
Sound of bell is the file "dingdong2.aiff".
When play begins:
	play sound of bell.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000995closed Core Inform cBlorb produces corrupted Blorbs when wrapping up AIFF files 

-  Notes
(0001815)
curiousdannii (developer)
2012-08-19 19:38

The Windows IDE doesn't support version 6 however.
(0001816)
DavidG (reporter)
2012-08-19 20:49

Poking around in the intermediate code, it seems to me that the only reason you can't have Zcode making sounds is because the library doesn't set things up right.
(0001818)
DavidK (developer)
2012-08-19 22:35
edited on: 2012-08-19 22:37

That library check for V6 is wrong - sounds are supported in Z-code from V3 onwards. There's no particular reason for I7 not supporting sounds in Z-code other than Graham not being keen.

One other thing to watch out for with this is the index numbers assigned to resources. The last time I looked at this resources started being numbered from 1, but in Z-code sound effects 1 and 2 are special values (indicating system beeps).

(0002357)
graham (administrator)
2014-01-25 08:53

I have clarified the documentation, but yes, I7 only supports sound on G.

- Issue History
Date Modified Username Field Change
2012-08-19 19:27 EmacsUser New Issue
2012-08-19 19:28 EmacsUser Relationship added related to 0000995
2012-08-19 19:38 curiousdannii Note Added: 0001815
2012-08-19 20:49 DavidG Note Added: 0001816
2012-08-19 22:36 DavidK Note Added: 0001818
2012-08-19 22:37 DavidK Note Edited: 0001818 View Revisions
2014-01-25 08:53 graham Note Added: 0002357
2014-01-25 08:53 graham Status new => resolved
2014-01-25 08:53 graham Resolution open => fixed
2014-01-25 08:53 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker