Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000994Core InformPropertiespublic2012-08-17 00:012014-05-07 07:33
Assigned Tograham 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000994: Using enumerable values as properties breaks relations
DescriptionThis code sets up an enumerable value kind, and a relation between them. If the kind is used as a property, then the relation cannot be specified after that point in the code.

It does work if the property is given a specific name.

This might be related to one of the umbrella issues?
Minimal Source Text To Reproduce
There is a room.

Faction is a kind of value. The factions are friendly, passive, hostile.

Hating relates various factions to various factions.
The verb to hate (he hates, they hate, he hated, it is hated, he is hating) implies the hating relation.

Friendly hates hostile.

A person has a faction [called factionb.] [Uncomment to fix]

Hostile hates friendly.
Additional InformationProblem. You wrote 'Hostile hates friendly' : but this seems to give a worldly relationship to something intangible, like saying that 'in the box is a text'. Perhaps it came to this because you gave something physical a name which was accidentally something meaningful to me in another context? If so, you may be able to get around it by rewording ('In the box is a medieval text') or in extremis by using 'called' ('In the box is a thing called text').
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
graham (administrator)
2014-03-15 02:26

Not strictly speaking a bug fix, but a worthwhile improvement to make, and it's now made.

- Issue History
Date Modified Username Field Change
2012-08-17 00:01 curiousdannii New Issue
2012-08-19 18:41 EmacsUser Relationship added child of 0000898
2012-08-19 18:42 EmacsUser Status new => confirmed
2014-03-09 16:03 graham Relationship deleted child of 0000898
2014-03-15 02:26 graham Note Added: 0002558
2014-03-15 02:26 graham Status confirmed => resolved
2014-03-15 02:26 graham Resolution open => fixed
2014-03-15 02:26 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker