Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000991Core InformRelationspublic2012-08-13 10:322014-05-07 07:34
Reportermattweiner 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000991: can't define a relation with "to"
DescriptionDefining a relation whose name ends with "to" leads to a compiler error. (And leaving out "to" in one place leads to an unexpected compiler failure.)
Minimal Source Text To Reproduce
"connect to failure" by Matt Weiner

Lab is a room.

Connecting to relates one room to one room.  The verb to connect to (he connects to, they connect to, 
he connected to, it is connected to, he is connecting to) implies the connecting to relation.
Additional InformationIf we try instead:

"connect to failure" by Matt Weiner

Lab is a room.

Connecting to relates one room to one room. The verb to connect to (he connects to, they connect to, he connected to, it is connected to, he is connecting to) implies the connecting relation.

then we get "The application ran your source text through the Inform 7 compiler, as usual, but the compiler unexpectedly failed.... When a program like the I7 compiler fails, it typically returns an error number: this time, the number was 10, and that probably indicates that the compiler failed to manage its data structures properly."
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships
child of 0000686closedgraham Umbrella issue: ni misses an alternative parsing of the source text 

-  Notes
(0001794)
zarf (developer)
2012-08-13 12:39

Problem message on the original test case:

Problem. You wrote 'The verb to connect to (he connects to, they connect to, he connected to, it is connected to, he is connecting to) implies the connecting to relation' : but new verbs can only be defined in terms of existing relations, all of which have names ending 'relation': thus '...implies the possession relation' is an example of a valid definition, this being one of the relations built into Inform.
(0001797)
EmacsUser (manager)
2012-08-13 15:47

The internal error is 0000582, but confirmed for the other failure.
(0002270)
graham (administrator)
2014-01-12 06:18

I can't reproduce this; seems to have been fixed as part of another fix. Anyway, works fine now.

- Issue History
Date Modified Username Field Change
2012-08-13 10:32 mattweiner New Issue
2012-08-13 12:40 zarf Note Added: 0001794
2012-08-13 15:47 EmacsUser Note Added: 0001797
2012-08-13 15:47 EmacsUser Status new => confirmed
2012-08-13 15:48 EmacsUser Relationship added child of 0000686
2014-01-12 06:18 graham Note Added: 0002270
2014-01-12 06:18 graham Status confirmed => resolved
2014-01-12 06:18 graham Resolution open => fixed
2014-01-12 06:18 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker