Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000099Core InformPhrases and functional programmingpublic2010-06-21 22:172010-07-01 23:07
ReporterAaronReed 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000099: Cannot move backdrops to regions with "now"
DescriptionThe documentation page 8.8 Moving Backdrops states that you can use either "move the stream to the Lower Level" or "now the stream is in the Lower Level" to move a backdrop to a region. However, only the former syntax works; the latter fails with the following problem message:

Problem. You wrote 'now the stream is in the Lower Level' : but this is not something I can make true with 'now', because it is too vague about the underlying cause which would need to be arranged.
Minimal Source Text To Reproduce
Lower Level is a region. The Rock Pool and the Ledge are in the Lower Level.

The stream is a backdrop.

When play begins: now the stream is in the Lower Level.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
(0000122)
graham (administrator)
2010-06-22 14:00

Fixed now. "In" is a tricky relation to interpret, since Inform distinguishes ordinary containment from region containment (they have very different behaviours). In simplifying propositions, Inform was assuming that "X is in R", where R is a region, means region containment, on the grounds that ordinary objects can't be in regions - only rooms and other regions; but that was, of course, not quite true, backdrops being the one exception allowed.

- Issue History
Date Modified Username Field Change
2010-06-21 22:17 AaronReed New Issue
2010-06-22 02:19 jmcgrew Severity mild => serious
2010-06-22 02:19 jmcgrew Status new => confirmed
2010-06-22 14:00 graham Note Added: 0000122
2010-06-22 14:00 graham Status confirmed => resolved
2010-06-22 14:00 graham Resolution open => fixed
2010-06-22 14:00 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker