Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000989Documentation, Examples, and Web SiteBug Tracker Sitepublic2012-08-11 15:232014-05-07 07:38
ReporterDavidG 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version6L02 
Summary0000989: Additional categories desirable for Inform6 projects
DescriptionI would like the Inform6 and Inform6 library projects to have some more categories -- not just "general". Please replace that with "bug" and "wishlist".
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001796)
EmacsUser (manager)
2012-08-13 15:37

I can add these, though I'm not sure we want them to be categories. Categories currently stand for pieces of each project (more or less), so that Parser, VerbLib, and Grammar would be the natural choices here. Perhaps a tag, like ``I6 library suggestion'' or ``I6 library wishlist'' would serve better? It's a little tricky to say, because we keep other projects' non-bugs at http://inform7.uservoice.com [^]–that would be another option.
(0001800)
zarf (developer)
2012-08-16 09:13

Categories for I6lib could reasonably parallel the I7 core:

Actions, parsing, world model, printing issues (banner, status line, list-maker), Glulx issues (graphics, sounds). Maybe also a category for language support (meaning internationalization/translation, not the I6 language).
(0001801)
zarf (developer)
2012-08-16 09:19

As for the compiler, I haven't felt any need for categories. But if I were to categorize I6 bugs, I'd go with:

Memory handling, errors, parsing, code generation, VM support, veneer, language (meaning I6 language features).
(0001802)
zarf (developer)
2012-08-16 09:22

(I do not want to handle I6 or I6lib feature requests through Uservoice. We don't have that level of demand, and we're not constrained by Graham's desire to clear out Mantis on every release.)
(0001840)
DavidG (reporter)
2012-09-08 15:20

I'll handle suggestions manually until it becomes too much hassle. Then I'll look for some other solution; maybe cook up something myself.
(0001842)
EmacsUser (manager)
2012-09-09 16:31

Okay. The offer still stands for category additions; just let me know if you want them.

- Issue History
Date Modified Username Field Change
2012-08-11 15:23 DavidG New Issue
2012-08-13 15:37 EmacsUser Note Added: 0001796
2012-08-13 15:37 EmacsUser Status new => feedback
2012-08-16 09:13 zarf Note Added: 0001800
2012-08-16 09:19 zarf Note Added: 0001801
2012-08-16 09:22 zarf Note Added: 0001802
2012-09-08 15:20 DavidG Note Added: 0001840
2012-09-08 15:20 DavidG Status feedback => new
2012-09-09 16:31 EmacsUser Note Added: 0001842
2014-01-25 10:19 graham Status new => resolved
2014-01-25 10:19 graham Resolution open => fixed
2014-01-25 10:19 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker