Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000984Core InformPhrases and functional programmingpublic2012-08-08 19:392014-05-07 07:33
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000984: Misquoted source text in problem message for an implicitly looped assignment
DescriptionIdeally, Inform would understand these sorts of sentences—with a kind of value like this, a workaround is to omit ``the status of'', but that doesn't work for, say, room-valued properties. In any case, the problem message mentions ``a person'', which seem substantially different from what the author wrote, ``every person'':

- - - -
Problem. In the sentence 'now the status of every person is attentive' , it looks as if you intend 'status of every person' to be a property, but 'a person' is not specific enough about who or what the owner is.
 Sometimes this mistake is made because Inform mostly doesn't understand the English language habit of referring to something indefinite by a common noun - for instance, writing 'change the carrying capacity of the container to 10' throws Inform because it doesn't understand that 'the container' means one which has been discussed recently.

 See the manual: 4.8 > New value properties
I was trying to match this phrase:

now (status of every person is attentive - a condition)
This was what I found out:

status of every person is attentive = a condition
- - - -
Minimal Source Text To Reproduce
There is a room.
Status is a kind of value.  The statuses are attentive and bored.  Every person has a status.
When play begins:
	now the status of every person is attentive.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-08-08 19:39 EmacsUser New Issue
2012-08-17 00:21 curiousdannii Status new => confirmed
2014-01-24 02:01 graham Status confirmed => resolved
2014-01-24 02:01 graham Resolution open => fixed
2014-01-24 02:01 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker