Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000098Core InformExtensionspublic2010-06-21 19:432010-07-01 23:07
Reporterektemple 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000098: Section replacements suppress extension versioning errors
DescriptionThe source text provided should inform the user that the correct version of Plurality is not available. Instead, it complains that the section we want to replace is not present. This is confusing--the versioning error should take precedence over all other extension warnings.
Minimal Source Text To Reproduce
"Test"

Include version 12 of Plurality by Emily Short.

Test is a room.

Section - Fake (in place of Section - Faker yet in Plurality by Emily Short)

This is the fake rule:
	do nothing.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0000130)
graham (administrator)
2010-06-22 16:08

An awkward timing issue, since at the time when Inform splices headings together, it hasn't yet worked out the versions it needs vs. the ones it has. I have reworded the problem message to be explicit about the version of the extension actually loaded:

Problem. In the sentence 'Section - Fake (in place of Section - Faker yet in Plurality by Emily Short)' , it looks as if you intend to replace a section of source text from the extension 'Plurality by Emily Short', but that extension does not seem to have any heading called 'Section - Faker yet'. (The version I loaded was 8.)

That will have to do.

- Issue History
Date Modified Username Field Change
2010-06-21 19:43 ektemple New Issue
2010-06-21 20:24 jmcgrew Status new => confirmed
2010-06-22 16:08 graham Note Added: 0000130
2010-06-22 16:08 graham Status confirmed => resolved
2010-06-22 16:08 graham Resolution open => fixed
2010-06-22 16:08 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker