Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000976I6 LibraryGeneralpublic2012-08-08 16:092015-05-10 17:46
ReporterDavidG 
Assigned ToDavidG 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6/11 
Target Version6/12Fixed in Version6/12 
Summary0000976: Numbers in the 'name' property
DescriptionOriginally reported by Roger Firth as Issue L61114

There seems to be progressive degrading in a bit of the library. Using the supplied test program, the output should be as follows:

  Release 1 / Serial number 050213 / Inform v6.21 Library 6/10 SD

  Bare room
  You are in a bare room.

  You can see a box marked 1 and a box marked 2 here.

  >X BOX 1
  It's a wooden box marked with the number 1.

  >X 1
  It's a wooden box marked with the number 1.

  >X BOX 2
  It's a wooden box marked with the number 2.

  >X 2
  It's a wooden box marked with the number 2.

Instead this happens:

  Release 1 / Serial number 050213 / Inform v6.30 Library 6/11 SD

  Bare room
  You are in a bare room.

  You can see a box marked 1 and a box marked 2 here.

  >X BOX 1
  It's a wooden box marked with the number 1.

  >X 1
  (the box marked 1)
  It's a wooden box marked with the number 1.

  >X BOX 2
  It's a wooden box marked with the number 2.

  >X 2
  What do you want to examine? ! <--- WRONG

  >BOX
  It's a wooden box marked with the number 2.

  >X 2
  It's a wooden box marked with the number 2.

Roger's tinkerings made it worse, as is shown here:

  Release 1 / Serial number 050213 / Inform v6.31 Library 6/12 SD

  Bare room
  You are in a bare room.

  You can see a box marked 1 and a box marked 2 here.

  >X BOX 1
  It's a wooden box marked with the number 1.

  >X 1
  What do you want to examine? ! <--- WRONG

  >BOX
  (the box marked 1)
  It's a wooden box marked with the number 1.

  >X BOX 2
  It's a wooden box marked with the number 2.

  >X 2
  What do you want to examine? ! <--- WRONG

  >BOX
  It's a wooden box marked with the number 2.

  >X 2
  It's a wooden box marked with the number 2.
Minimal Source Text To Reproduce
Include "Parser";
Include "VerbLib";
Include "Grammar";

[ Initialise; location = Home; ];

Object  Home "Bare room"
  with  description "You are in a bare room.",
  has   light;

Object  -> box1 "box marked 1"
  with  name 'box' 'marked' '1//',
        description "It's a wooden box marked with the number 1.";

Object  -> box2 "box marked 2"
  with  name 'box' 'marked' '2//',
        description "It's a wooden box marked with the number 2.";
Additional Informationhttp://inform-fiction.org/patches/L61114.html [^]
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001784)
DavidG (developer)
2012-08-09 16:58

This simple patch was suggested. It's not clear if this will cause any problems, but I'll put it in the codebase anyhow and keep an eye on it.

 parserm.h | 5 ++++-
 1 files changed, 4 insertions(+), 1 deletions(-)

diff --git a/parserm.h b/parserm.h
index 1b9e976..cda7658 100644
--- a/parserm.h
+++ b/parserm.h
@@ -2518,7 +2518,10 @@ Constant UNLIT_BIT = 32;
 
     if (o == ME1__WD or ME2__WD or ME3__WD) { pronoun_word = o; pronoun_obj = player; }
 
- allow_plurals = true; desc_wn = wn;
+! L61114 fix by Nathan Schwartzman
+! Not sure if this will cause any regressions
+! allow_plurals = true;
+ desc_wn = wn;
 
   .TryAgain;
(0002786)
DavidG (developer)
2014-05-16 18:45

Looks like it's still causing trouble.
(0002794)
DavidG (developer)
2014-05-18 22:52

Fix submitted by Nathan Schwartzman. He worked out what was changed between 6/10 and 6/11 pertaining to this bug and put that code back. As-is, it introduced a problem with TAKE ALL. I attributed this to a double-negation. Once that was removed, L61114 appears to be fixed and no side-effects appear evident.

https://github.com/DavidGriffith/inform6lib/commit/6ddb43df0dae5f1d9774f0410e453ce38619a1c3 [^]
(0003462)
jmcgrew (administrator)
2015-05-10 17:46

Closing all resolved issues from 2014 and earlier.

- Issue History
Date Modified Username Field Change
2012-08-08 16:09 DavidG New Issue
2012-08-09 16:27 DavidG Assigned To => DavidG
2012-08-09 16:27 DavidG Status new => acknowledged
2012-08-09 16:27 DavidG Assigned To DavidG =>
2012-08-09 16:50 DavidG Assigned To => DavidG
2012-08-09 16:50 DavidG Status acknowledged => assigned
2012-08-09 16:58 DavidG Note Added: 0001784
2012-08-09 20:47 DavidG Status assigned => feedback
2012-08-09 21:03 DavidG Assigned To DavidG =>
2012-10-07 18:15 DavidG Assigned To => DavidG
2012-10-07 18:15 DavidG Status feedback => assigned
2014-05-16 18:45 DavidG Note Added: 0002786
2014-05-18 22:52 DavidG Note Added: 0002794
2014-05-18 22:52 DavidG Status assigned => resolved
2014-05-18 22:52 DavidG Fixed in Version => 6/12
2014-05-18 22:52 DavidG Resolution open => fixed
2014-08-28 20:11 DavidG Additional Information Updated View Revisions
2015-05-10 17:46 jmcgrew Note Added: 0003462
2015-05-10 17:46 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker