Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000974I6 LibraryGeneralpublic2012-08-08 15:372015-05-10 17:47
ReporterDavidG 
Assigned ToDavidG 
PrioritynormalSeveritymildReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6/11 
Target Version6/12Fixed in Version6/12 
Summary0000974: ListMaker doesn't support 'serial' commas
DescriptionOriginally reported by Andrew Plotkin as Issue L61104

The WriteListFrom() listmaker doesn't support 'serial' commas (aka Oxford or Harvard commas): Tom, Dick, and Harry.

A patch from Andrew is attached. It probably won't work against the current repo, so it'll have to be parsed and applied manually.
Additional InformationUpdate by Cedric Knight

It looks like translators would have to add two more string constants. This could be avoided, and also the code size reduced for existing behaviour, if the implementation were instead as a routine SerialComma(items); which would print a comma iff items>2 and the SERIAL_COMMAS constant were defined.
TagsNo tags attached.
Attached Filespatch file icon serialcomma.patch [^] (8,177 bytes) 2012-08-08 15:37 [Show Content]

- Relationships

-  Notes
(0001792)
DavidG (developer)
2012-08-11 16:19

This is also Suggestion 101
(0001841)
DavidG (developer)
2012-09-09 13:23

done
(0003715)
jmcgrew (administrator)
2015-05-10 17:47

Closing all resolved issues from 2014 and earlier.

- Issue History
Date Modified Username Field Change
2012-08-08 15:37 DavidG New Issue
2012-08-08 15:37 DavidG File Added: serialcomma.patch
2012-08-08 16:04 DavidG Description Updated View Revisions
2012-08-11 16:19 DavidG Note Added: 0001792
2012-09-09 13:23 DavidG Note Added: 0001841
2012-09-09 13:23 DavidG Status new => resolved
2012-09-09 13:23 DavidG Fixed in Version => 6/12
2012-09-09 13:23 DavidG Resolution open => fixed
2012-09-09 13:23 DavidG Assigned To => DavidG
2015-05-10 17:47 jmcgrew Note Added: 0003715
2015-05-10 17:47 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker