Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000973I6 LibraryGeneralpublic2012-08-08 15:322014-06-01 02:33
ReporterDavidG 
Assigned ToDavidG 
PrioritynormalSeveritymildReproducibilityhave not tried
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version6/11 
Target Version6/12Fixed in Version6/12 
Summary0000973: "statusline time;" statement isn't recognized
DescriptionOriginally reported by Howard Sherman as Issue L61103

When I compile Greystone with 6.30 and 6/11 my statusline time; statement is seemingly ignored; the game runs by moves and not a clock. If I revert back to 6.21 and 6/10 the statusline is indeed a clock again and not a move counter.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0002812)
DavidG (developer)
2014-05-21 23:00
edited on: 2014-05-21 23:02

I successfully contacted Howard Sherman. He is now looking for the source code to Greystone for me. He will either send me a test game to demonstrate the bug or send me the the whole source code under NDA so I can distill a test case that can be disclosed publicly.

(0002814)
DavidG (developer)
2014-05-24 00:43

Nathan Schwartzman proposed the fix below:

Try adding this in ParserM.h before Initialise is first called:
if (sys_statusline_flag ~= 0) the_time = 0;

This isn't a reversion to 6/10 behavior but it appears to work. However it
would probably be best to identify exactly what was changed between 6/10 and
6/11 that broke this.
(0002853)
DavidG (developer)
2014-06-01 02:29

I think I have misunderstood this bug report. I was under the impression that "Greystone" used a real-time clock and this clock wasn't running. As far as I can determine, the Library never had built-in support for a "Border Zone" style clock. In my tests, "Statusline time;" does indeed cause the status line to show a clock for 6/10, 6/11, and 6/12. I am therefore closing this Issue.

- Issue History
Date Modified Username Field Change
2012-08-08 15:32 DavidG New Issue
2012-08-08 16:04 DavidG Description Updated View Revisions
2012-10-07 18:16 DavidG Assigned To => DavidG
2012-10-07 18:16 DavidG Status new => assigned
2014-05-21 23:00 DavidG Note Added: 0002812
2014-05-21 23:02 DavidG Note Edited: 0002812 View Revisions
2014-05-24 00:43 DavidG Note Added: 0002814
2014-06-01 02:29 DavidG Note Added: 0002853
2014-06-01 02:29 DavidG Status assigned => resolved
2014-06-01 02:29 DavidG Resolution open => fixed
2014-06-01 02:30 DavidG Status resolved => acknowledged
2014-06-01 02:32 DavidG Note Added: 0002854
2014-06-01 02:32 DavidG Status acknowledged => closed
2014-06-01 02:32 DavidG Fixed in Version => 6/12
2014-06-01 02:33 DavidG Resolution fixed => unable to reproduce
2014-06-01 02:33 DavidG Note Deleted: 0002854


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker