Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000967Core InformSource text and punctuationpublic2012-08-05 10:042014-05-07 07:34
Reporterjmcgrew 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000967: "The <kind>" should be flagged as an error
DescriptionNew authors frequently seem to write things like "instead of going to a room when the room is not visited", intending "the room" to mean some particular room, but I7 treats it the same as "a room" and produces unexpected behavior. The syntax should just be rejected at compile time, since it never means what anyone expects it to mean.
Minimal Source Text To Reproduce
Kitchen is a room.  South is Hallway.  North is Pantry.
Instead of going to a room when the room is not visited:
	showme whether or not the room gone to is visited; [one would expect the result to always be false]
	
make no decision.
Test me with "s/n".
Additional InformationTaken almost verbatim from http://inform7.uservoice.com/forums/57320-general/suggestions/754190-syntax-flag-the-kind-as-an-error. [^]
TagsNo tags attached.
Effect(mild) Compiler accepts invalid code
Attached Files

- Relationships

-  Notes
(0001951)
graham (administrator)
2013-01-02 10:46

This now produces an explanatory problem message.

- Issue History
Date Modified Username Field Change
2012-08-05 10:04 EmacsUser New Issue
2012-08-05 10:05 EmacsUser Reporter EmacsUser => jmcgrew
2012-08-05 10:05 EmacsUser Status new => confirmed
2013-01-02 10:46 graham Note Added: 0001951
2013-01-02 10:46 graham Status confirmed => resolved
2013-01-02 10:46 graham Resolution open => fixed
2013-01-02 10:46 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker