Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000964Documentation, Examples, and Web SiteWriting with Informpublic2012-08-05 06:002014-05-07 07:38
Assigned Tograham 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version6L02 
Summary0000964: WI 12.6 should explain that, in contrast with orders and WI 12.5, unsuccessful spontaneous actions print nothing for failure
DescriptionBased on a report originally against core Inform:

The action fails as it should do, but there is no error message saying that the action has failed.
Minimal Source Text To Reproduce

Instead of thinking, try mr monkey singing.

The Testing Room is A Room. Mr Monkey is a person in the testing room.

Test me with "think".
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
EmacsUser (manager)
2012-08-05 10:33

It seems like this is correct behavior: instead rules are expected to print responses themselves, and spontaneous NPC actions aren't expected to report failures. Based on the fact that you have a persuasion rule, perhaps you meant

- - - -
Instead of thinking, try asking mr monkey to try singing.
- - - -

climbingstars (reporter)
2012-08-08 13:45

Actually, the persuasion rule isn't relevant and was left in accidentally. The same problem occurs if it were a check rule rather than an instead rule.

I'm not sure whether this is intentional, but I rather thought that it would be more suitable for inform to give an error message instead of leaving a blank line.
EmacsUser (manager)
2012-08-08 18:25
edited on: 2012-08-08 18:26

I can see arguments both ways, but this is intentional. There's an explicit special case in the template layer:

- - - -
[ GL__M a b c d;
    if ((actor ~= player) || (untouchable_silence)) rtrue;
    return L__M(a,b,c,d); ];
- - - -

WI 12.6 almost explains this; it points out that ``when such actions fail, they invoke no special set of rules.'' Perhaps it should further state that the check rules will not print any text—that would make this a documentation bug.

Note that, for cases where the author does want to generate an error message, try statements set the variable ``the reason the action failed'', which the instead/check rule or one of its callees can then consult.

climbingstars (reporter)
2012-08-10 10:22

I see. I guess it would be better to clarify this in the documentation.
EmacsUser (manager)
2012-08-10 17:05

Okay; I've converted the report. Thanks for filing it.

- Issue History
Date Modified Username Field Change
2012-08-05 06:00 climbingstars New Issue
2012-08-05 10:33 EmacsUser Note Added: 0001765
2012-08-05 10:33 EmacsUser Status new => feedback
2012-08-08 13:45 climbingstars Note Added: 0001777
2012-08-08 13:45 climbingstars Status feedback => new
2012-08-08 18:25 EmacsUser Note Added: 0001781
2012-08-08 18:25 EmacsUser Status new => feedback
2012-08-08 18:25 EmacsUser Note Edited: 0001781 View Revisions
2012-08-08 18:26 EmacsUser Note Edited: 0001781 View Revisions
2012-08-10 10:22 climbingstars Note Added: 0001789
2012-08-10 10:22 climbingstars Status feedback => new
2012-08-10 16:59 EmacsUser Project Core Inform => Documentation, Examples, and Web Site
2012-08-10 17:05 EmacsUser Note Added: 0001791
2012-08-10 17:05 EmacsUser Reproducibility always => N/A
2012-08-10 17:05 EmacsUser Status new => confirmed
2012-08-10 17:05 EmacsUser Category Model world => Writing with Inform
2012-08-10 17:05 EmacsUser Summary Blank line given when NPC tries an action that fails => WI 12.6 should explain that, in contrast with orders and WI 12.5, unsuccessful spontaneous actions print nothing for failure
2012-08-10 17:05 EmacsUser Description Updated View Revisions
2012-08-10 17:05 EmacsUser Steps to Reproduce Updated View Revisions
2014-01-25 08:47 graham Status confirmed => resolved
2014-01-25 08:47 graham Resolution open => fixed
2014-01-25 08:47 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker