Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000952Core InformListspublic2012-07-22 12:492014-05-07 07:33
Reporterdg 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000952: Errors in lists of texts are reported incorrectly
DescriptionIf I try to create a list of texts which contains an error --- such as an invalid text substitution --- the error is reported as belonging to entirely the wrong thing. The attached example reports:

---snip---
Problem. In the line 'Understand "switch [something switched on]" as switching off', I was expecting that 'Q' would be something to 'say', but it didn't look like any form of 'say' that I know. So I tried to read 'Q' as a value of some kind (because it's legal to say values), but couldn't make sense of it that way either.
---snip---
Minimal Source Text To Reproduce
Place is a room.

When play begins:
	let T be {"[Q]"};
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-07-22 12:49 dg New Issue
2012-07-25 23:34 curiousdannii Effect (serious/mild) Game compiles but misbehaves => (cosmetic) Error message is badly worded
2012-07-25 23:34 curiousdannii Severity serious => cosmetic
2012-07-25 23:34 curiousdannii Reproducibility have not tried => always
2012-07-25 23:34 curiousdannii Status new => confirmed
2012-07-25 23:34 curiousdannii Category Kinds and type checking => Lists
2012-07-25 23:34 curiousdannii Description Updated View Revisions
2012-07-25 23:34 curiousdannii Steps to Reproduce Updated View Revisions
2014-01-24 01:46 graham Status confirmed => resolved
2014-01-24 01:46 graham Resolution open => fixed
2014-01-24 01:46 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker