Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000095Core InformRelationspublic2010-06-21 14:522010-10-28 00:30
Reporterfundin 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000095: Static symmetric one-to-one relations of values are created as asymmetric (with solution)
DescriptionThis is the output produced by the example source:

R1 is symmetric.
Test failed.
Minimal Source Text To Reproduce
Home is a room.

R1 relates one number to another.

When play begins:
	now the R1 relation relates 3 to 7;
	say "R1 is [if the R1 relation is not symmetric]not [end if]symmetric.";
	say "Test [if the R1 relation relates 7 to 3]succeeded[otherwise]failed[end if]."
Additional InformationThis does not happen with a relation of things, nor with a dynamically created relation, nor with a static symmetric various-to-various relation of values. As can be seen, the relation claims to be symmetric, but it isn't really.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Filespatch file icon symmetric_o2o_eqv_relations.patch [^] (1,072 bytes) 2010-06-21 20:17 [Show Content]

- Relationships

-  Notes
(0000112)
jmcgrew (administrator)
2010-06-21 17:45

Something to do with the staticness... this works:

<code>
Home is a room.

R1 is a relation of numbers to numbers that varies.

When play begins:
now R1 is symmetric;
now R1 relates 3 to 7;
say "R1 is [if R1 is not symmetric]not [end if]symmetric.";
say "Test [if R1 relates 7 to 3]succeeded[otherwise]failed[end if]."
</code>
(0000114)
jmcgrew (administrator)
2010-06-21 20:20

Whoops, that wasn't it at all; that working case makes a various-to-various relation.

The problem was that valency changes, like the generated code does to make a newly created relation symmetric, were not taking effect for one-to-one relations (or equivalence relations). The attached patch fixes it.
(0000517)
graham (administrator)
2010-09-04 15:28

All credit to Jesse; patch adopted.

- Issue History
Date Modified Username Field Change
2010-06-21 14:52 fundin New Issue
2010-06-21 17:31 jmcgrew Assigned To => jmcgrew
2010-06-21 17:31 jmcgrew Status new => confirmed
2010-06-21 17:45 jmcgrew Note Added: 0000112
2010-06-21 20:17 jmcgrew File Added: symmetric_o2o_eqv_relations.patch
2010-06-21 20:20 jmcgrew Note Added: 0000114
2010-06-21 20:20 jmcgrew Summary Static symmetric one-to-one relations of values are created as asymmetric => Static symmetric one-to-one relations of values are created as asymmetric (with solution)
2010-06-21 20:21 jmcgrew Assigned To jmcgrew =>
2010-09-04 15:28 graham Note Added: 0000517
2010-09-04 15:28 graham Status confirmed => resolved
2010-09-04 15:28 graham Resolution open => fixed
2010-09-04 15:28 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker