Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000948Documentation, Examples, and Web SiteWriting with Informpublic2012-07-20 10:092014-05-07 07:38
Reporterotistdog 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityN/A
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000948: Request to increase the clarity of documentation in 16.21
DescriptionThe documentation in section 16.21 describing precedence of grammar line processing may be interpreted as holding true in all cases, when, in fact, it seems to hold true only within certain subgroups not described by the documentation. For example, all one-noun lines seem to be processed before any two-noun lines, even though two-noun lines would seem to be "more specific" as described in the documentation.

Ideally, I would like I7 to behave as I originally interpreted 16.21 to mean, using the number of tokens as part of what drives specificity. This would prevent issues like the one I ran into with Bug 943 (http://inform7.com/mantis/view.php?id=943 [^]). In the absence of that change, it may be helpful to new authors to provide more detail about the rules around grammar line precedence.
Minimal Source Text To Reproduce
"A Bug Report" by "Otis T. Dog"


Place is a room.

The player is holding an openable open container called the briefcase. A brass tab is part of the briefcase. 
A leather slot is part of the briefcase. A brass nameplate is part of the briefcase.

Does the player mean inserting the tab into the slot: it is very likely.

Instead of inserting the tab into the slot, try closing the briefcase instead.

test me with "trace / put brass in slot / insert brass into slot"

[Note that for command "put brass in slot" the grammar for the "wear" action triggers 
disambiguation even though naively:

	1) this would not seem to be an applicable grammar line, and
	2) the applicable grammar line seeems to be more specific because it requires a second noun.

The "does the player mean" rule is apparently never even considered.]

TagsNo tags attached.
Attached Files

- Relationships
related to 0000633closedgraham Core Inform "does the player mean" not working with inserting action 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-07-20 10:09 otistdog New Issue
2012-07-21 05:15 EmacsUser Project Core Inform => Documentation, Examples, and Web Site
2012-07-21 05:16 EmacsUser Status new => confirmed
2012-07-21 05:16 EmacsUser Category Understanding => Writing with Inform
2012-07-21 05:16 EmacsUser Severity cosmetic => mild
2012-07-21 05:27 EmacsUser Relationship added related to 0000943
2012-07-21 05:30 EmacsUser Relationship added related to 0000633
2012-07-21 05:30 EmacsUser Relationship deleted related to 0000943
2014-01-25 08:09 graham Status confirmed => resolved
2014-01-25 08:09 graham Resolution open => fixed
2014-01-25 08:09 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker