Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000933Core InformSource text and punctuationpublic2012-06-14 18:232014-05-07 07:34
Assigned Tograham 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000933: Confusing problem message about changing kind when the word ``random'' is omitted
DescriptionThe attached source provokes

- - - -
Problem. You wrote 'now yourself is in the home that shelters yourself' : but the kind of something is fixed, and cannot be changed during play with a 'now'.
- - - -

but, because of the intervening ``in'' and the definite article, it's not immediately clear what that line and error have to do with each other.
Minimal Source Text To Reproduce
A home is a kind of room.  There is a home.
Dwelling relates a person to a home.  The verb to shelter (it shelters, they shelter, it sheltered, he 
is sheltered, it is sheltering) implies the reversed dwelling relation.
When play begins:
	now yourself is in the [random] home that shelters yourself.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-06-14 18:23 EmacsUser New Issue
2012-06-14 21:37 curiousdannii Status new => confirmed
2014-01-22 15:03 graham Status confirmed => resolved
2014-01-22 15:03 graham Resolution open => fixed
2014-01-22 15:03 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker