Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000925Core InformAssertions and creationspublic2012-05-25 09:112014-05-07 07:34
ReporterChrisC 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSWindows 7OS VersionSP1
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000925: Initializing a nonexistent property using an overloaded past tense verb crashes NI
DescriptionOriginally encountered in writing a "read [something]" routine for many objects; the property was actually called "readable text". Typos could easily lead to this, for example.
Minimal Source Text To Reproduce
There is room.

The verb to be read implies the printed text property.

Yourself is read "hah!"
Additional InformationTranslating the Source - Failed

The application ran your source text through the Inform 7 compiler, as usual, but the compiler unexpectedly failed. This should not happen even if your source text is gibberish, so you may have uncovered a bug in the program.

When a program like the I7 compiler fails, it typically returns an error number: this time, the number was 10, and that probably indicates that the compiler failed to manage its data structures properly. Perhaps you created a complicated situation on which it has not been fully tested.

The best option now is probably to reword whatever was last changed and to try again. Subsequent attempts will not be affected by the failure of this one, so there is nothing to be gained by restarting the application or the computer. A failed run should never damage the source text, so your work cannot be lost.

If you think it likely that the Inform 7 compiler is at fault, please check that you have the currently distributed build of the system: if you have, please consider taking the time to fill out a bug report at the Inform bug tracker (www.inform7.com/bugs). If you think the fault may be due to a problem in an extension you're using, then please contact the extension's author directly.


Sorry for the inconvenience.
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships

-  Notes
(0001675)
EmacsUser (manager)
2012-05-28 11:36

Confirmed:

- - - -
Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000004
0x0003bef2 in Problems__issue_problem_segment ()
(gdb) bt
#0 0x0003bef2 in Problems__issue_problem_segment ()
#1 0x0009230f in Problems__tcp_problem ()
#2 0x00092464 in Properties__Valued__Relations__Setting__typecheck ()
#3 0x000e09ad in type_check_binary_predicate ()
#4 0x000c9acb in Calculus__Propositions__type_check ()
#5 0x0011bc7f in prop_true_in_model ()
#6 0x0011cdb3 in prop_true_in_world_model_inner ()
#7 0x00123cb0 in Calculus__Propositions__assert_true ()
#8 0x001258f3 in Parser__Assertions__assert_subtree_in_relationship ()
#9 0x00134156 in make_assertion_recursive_inner ()
#10 0x00135d75 in Parser__Assertions__make_assertion_recursive ()
#11 0x00136e74 in Parser__Assertions__make_assertion ()
#12 0x00137e19 in to_be ()
#13 0x000a3673 in Parser__Assertions__traverse ()
#14 0x0012b971 in Config__Template__interpret ()
#15 0x001314bc in main ()
(gdb)
- - - -
(0002253)
graham (administrator)
2014-01-05 11:01

The cruellest kind of crash: when Inform correctly identifies the problem, then at the last moment blunders while trying to tell the user. Fixed, anyway.

- Issue History
Date Modified Username Field Change
2012-05-25 09:11 ChrisC New Issue
2012-05-28 11:36 EmacsUser Note Added: 0001675
2012-05-28 11:36 EmacsUser Status new => confirmed
2014-01-05 11:01 graham Note Added: 0002253
2014-01-05 11:01 graham Status confirmed => resolved
2014-01-05 11:01 graham Resolution open => fixed
2014-01-05 11:01 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker