Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000917Core InformKinds and type checkingpublic2012-05-08 14:552014-05-07 07:34
Assigned Tograham 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000917: Problem message reports that a value of kind description of people has the kind person
DescriptionThe attached source provokes

- - - -
Problem. You wrote 'Instead of examining when the current action involves a person', but 'person' seems to be a person, whereas I was expecting to find an object there.
I was trying to match this phrase:

(current action - stored action) involves (person - object)
This was what I found out:

current action = an instruction to work out a stored action, which results in a stored action
person = a description of people

- - - -

and in particular

- - - -
...'person' seems to be a person...
...person = a description of people...
- - - -

which reads as a contradiction.
Minimal Source Text To Reproduce
There is a room.
Instead of examining when the current action involves a person:
	do nothing.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships
has duplicate 0001129closed People can only be placed in scope one at a time 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-05-08 14:55 EmacsUser New Issue
2012-06-20 07:50 curiousdannii Status new => confirmed
2013-08-20 08:03 zarf Relationship added has duplicate 0001129
2014-01-22 15:01 graham Status confirmed => resolved
2014-01-22 15:01 graham Resolution open => fixed
2014-01-22 15:01 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker