Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000911Core InformIndexingpublic2012-04-24 19:272014-05-07 07:34
ReporterNYKevin 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000911: Conflating rooms and doors causes the compiler to report an internal error
DescriptionThe compiler doesn't seem to like it when the built-in kinds are messed with...

My guess is that the compiler is trying to put foo into bar and vice versa, and not realizing it's an infinite regress. Which means there's a problem in detecting such infinite regresses, which could (theoretically) manifest itself in other, more pervasive bugs.
Minimal Source Text To Reproduce
A room is a kind of door.

Foo is a room.
West of Foo is Bar.
West of Bar is Foo.
Additional Information  >--> An internal error has occurred: MAX_OBJECT_INDEX_DEPTH exceeded. The
    error was detected at line 181 of "Chapter 11/Index Physical World.w". This
    should never happen, and I am now halting in abject failure.
  >--> An internal error has occurred: MAX_OBJECT_INDEX_DEPTH exceeded. The
    error was detected at line 181 of "Chapter 11/Index Physical World.w". This
    should never happen, and I am now halting in abject failure.

[the error appears twice in the "Progress" tab]
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships
has duplicate 0000907closedgraham "A thing is a kind of room" produces internal error 

-  Notes
(0001663)
EmacsUser (manager)
2012-04-25 15:03

Looks like infinite recursion in the indexing code. (I get the same error, but only once.)
(0002072)
graham (administrator)
2013-06-01 12:39

Fixed, and problem messages added to stop people making the fundamental spatial kinds "thing" and "room" kinds of anything else.

- Issue History
Date Modified Username Field Change
2012-04-24 19:27 NYKevin New Issue
2012-04-25 15:03 EmacsUser Note Added: 0001663
2012-04-25 15:03 EmacsUser Reproducibility have not tried => always
2012-04-25 15:03 EmacsUser Status new => confirmed
2012-04-25 15:03 EmacsUser Category Kinds and type checking => Indexing
2013-06-01 12:39 graham Note Added: 0002072
2013-06-01 12:39 graham Status confirmed => resolved
2013-06-01 12:39 graham Resolution open => fixed
2013-06-01 12:39 graham Assigned To => graham
2013-06-01 12:40 graham Relationship added has duplicate 0000907
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker