Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000906Core InformKinds and type checkingpublic2012-04-17 19:102014-05-07 07:34
ReporterNYKevin 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000906: Compiler produces unlimited repetitions of same error when doing dubious things with kind hierarchy
DescriptionIn the source code provided, we (unwisely) make a thing into a kind of direction. As a result, Inform produces a lot of copies of the same error. Worse, the last one is cut off, implying the compiler crashed. I've tentatively categorized this as "Compiler hangs" since it's certainly *trying* to hang, although not succeeding.

To top it all off, I don't understand why that particular error message applies to that particular line of code in any event!
Minimal Source Text To Reproduce
A thing is a kind of direction.

There is room.
Additional Information  >--> You wrote 'The yourself is an undescribed person' (the Standard Rules, line 624):
    but nameless directions are not allowed, so writing something like 'There
    is a direction.' is forbidden.
  >--> You wrote 'The yourself is an undescribed person' (the Standard Rules, line 624):
    again, nameless directions are not allowed.

Repeat the second one a *lot* and then:

  >--> You wrote 'The yourself is an undescribed person' (the Standard Rules, line 624):
    again, nameless directions are n
TagsNo tags attached.
Effect(critical) Compiler hangs
Attached Files

- Relationships

-  Notes
(0002073)
graham (administrator)
2013-06-01 13:02

Related to, but not a duplicate of, 0000911; fixed.

- Issue History
Date Modified Username Field Change
2012-04-17 19:10 NYKevin New Issue
2012-04-25 14:49 EmacsUser Reproducibility have not tried => always
2012-04-25 14:49 EmacsUser Status new => confirmed
2013-06-01 13:02 graham Note Added: 0002073
2013-06-01 13:02 graham Status confirmed => resolved
2013-06-01 13:02 graham Resolution open => fixed
2013-06-01 13:02 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker