Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000900Core InformSource text and punctuationpublic2012-04-04 11:192014-05-07 07:33
Reporterherrdu 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000900: Inform gets the player global mixed up with player object.
DescriptionWhen run the if the player carries something refers to the player global variable (yourself), but the list of things carried by the player refers to the DVD player. Commenting the DVD player out produces the expected behavior.

test
An Interactive Fiction
Release 1 / Serial number 120404 / Inform 7 build 6G60 (I6/v6.32 lib 6/12N) SD

Example
You can see a DVD player here.

>i
You are carrying:
  a doo-dad

You are carrying nothing.

>
Minimal Source Text To Reproduce
"test"
 
Example is a room.  A DVD player is in example.

Yourself carries a doo-dad.  Every turn: if the player carries something, say "You are carrying 
[a list of things carried by the player]."
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
duplicate of 0000956closedgraham Names with 'player' in confuse the parser 
related to 0000898closedgraham Umbrella issue: Inform allows duplicate names, but will only try one meaning when parsing the source text. 

-  Notes
(0002144)
zarf (developer)
2013-10-19 13:15

Marking as a duplicate of 956 (even though that was filed later -- it has more detail and discussion).
(0002548)
graham (administrator)
2014-03-10 15:28

Fixed. Strictly speaking it's not a duplicate of 0000956, despite appearances, but the fix ran on very similar lines.

- Issue History
Date Modified Username Field Change
2012-04-04 11:19 herrdu New Issue
2012-04-04 17:56 EmacsUser Reproducibility have not tried => always
2012-04-04 17:56 EmacsUser Status new => confirmed
2012-04-04 17:56 EmacsUser Category Kinds and type checking => Source text and punctuation
2012-04-04 17:56 EmacsUser Relationship added related to 0000898
2013-10-19 13:14 zarf Relationship added duplicate of 0000956
2013-10-19 13:15 zarf Note Added: 0002144
2014-03-10 15:28 graham Note Added: 0002548
2014-03-10 15:28 graham Status confirmed => resolved
2014-03-10 15:28 graham Resolution open => fixed
2014-03-10 15:28 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker