Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000899Core InformSource text and punctuationpublic2012-03-30 22:492014-05-07 07:34
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000899: Umbrella issue: Inform rejects description literals in several cases
DescriptionSeveral variations on this theme are summarized in the attached source.
Minimal Source Text To Reproduce
[0000888:0001619: Unable to initialize description that varies with a description literal; Inform apparently 
tries to create ``interesting collection'' as an even number]
There is room.
The interesting collection is a (description of numbers) that varies.
The interesting collection is even numbers.
[Before reading 'The interesting collection is even numbers', I already knew that 'interesting collection' 
is a non-temporary variable, and it is too late to change now.]

[0000891: Unable to initialize list of descriptions with a description literal; Inform interprets ``even 
numbers'' as a new object name]
There is room.
The interesting list is a list of descriptions of numbers that varies.
The interesting list is {even numbers}.
[The sentence 'The interesting list is {even numbers}' tells me that 'interesting list', which is a list 
of descriptions of numbers that varies, should start out with the value '{ even numbers }', but this 
is a list of objects and not a list of descriptions of numbers.]

[889: Unable to initialize table of descriptions with a description literal; Inform responds with a specific 
error message for this case, although descriptions can be stored in table entries]
There is room.

Table 1
Collection
Descriptions of numbers
Even numbers
[In the table 1, the entry 'Even numbers' is a general description of things with no definite value, 
and can't be stored as a table entry.]

[0000887: Unable to assign to a local description from a description literal; Inform reports a bogus kind 
error]
There is room.
When play begins:
	let D be a description of numbers;
	let D be even numbers.
[You wrote 'let D be even numbers', but 'even numbers' seems to be a description of numbers, whereas 
I was expecting to find a value there.
	I was trying to match one of these phrases:
		1. let (d - a new name) be (even numbers - description of relations of values to values) 
		2. let (d - a new name) be (even numbers - name of kind) 
		3. let (d - a new name) be (even numbers - value) 
		4. let (d - a temporary named value) be (even numbers - value) 
	This was what I found out:
		D = a temporary named value, holding a description of numbers
		even numbers = a description of numbers]
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships
parent of 0000887closedgraham Cannot assign literal values to "description of K" variables 
parent of 0000889closedgraham Tables of descriptions cannot be populated at compile-time 
parent of 0000891closedgraham Description interpreted as object name 

-  Notes
(0002324)
graham (administrator)
2014-01-19 06:54

For now, Inform just isn't good at managing the ambiguities here. Eventually the solution will probably be to have a delineated syntax for descriptions used as values - e.g., "the description "even numbers"". But in the next build, it's simply going to improve its problem messages, and check more carefully.

- Issue History
Date Modified Username Field Change
2012-03-30 22:49 EmacsUser New Issue
2012-03-30 22:50 EmacsUser Relationship added related to 0000887
2012-03-30 22:50 EmacsUser Relationship added related to 0000889
2012-03-30 22:50 EmacsUser Relationship added related to 0000891
2012-03-31 19:57 jmcgrew Relationship replaced parent of 0000887
2012-03-31 19:57 jmcgrew Relationship replaced parent of 0000889
2012-03-31 19:57 jmcgrew Relationship replaced parent of 0000891
2012-03-31 19:59 jmcgrew Status new => confirmed
2014-01-19 06:54 graham Note Added: 0002324
2014-01-19 06:54 graham Status confirmed => resolved
2014-01-19 06:54 graham Resolution open => fixed
2014-01-19 06:54 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker