Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000888Core InformAssertions and creationspublic2012-03-19 18:392014-05-07 07:34
ReporterNYKevin 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000888: Inform refuses to create global variables holding a "description of K"
DescriptionIt is impossible to create global variables which hold descriptions. Even if this is an intentional limitation in Inform, the error message is extremely odd and seems to think that this involves properties. This makes me think that Inform is misinterpreting the word "of".
Minimal Source Text To Reproduce
"Test"

There is room.

The interesting collection is a description of numbers that varies.
Additional InformationRelated to 887.

Adding the sentence "It is even numbers." to the end produces another bizarre error, this time about "an accidental clash of names".
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships
child of 0000686closedgraham Umbrella issue: ni misses an alternative parsing of the source text 

-  Notes
(0001610)
EmacsUser (manager)
2012-03-20 12:07

I'm going to call this one a bug in the source text parser, a relative or duplicate of 0000686. A workaround:

- - - -
The interesting collection is a (description of numbers) that varies.
- - - -
(0001619)
NYKevin (reporter)
2012-03-25 09:15

OK, that works, but the assignment is still broken:

Problem. Before reading 'The interesting collection is even numbers' , I already knew that 'interesting collection' is a non-temporary variable, and it is too late to change now.

I tried bracketing "even numbers" but Inform didn't like it:
Problem. You wrote 'The interesting collection is (even numbers)' : but this seems to give something a name which contains brackets '(' or ')', which is not allowed since the potential for confusion with other uses for brackets in Inform source text is too high. (If you need, say, a room which the player sees as 'Fillmore (West)', you can get this effect with: 'Fillmore West is a room with printed name "Fillmore (West)".')
(0002320)
graham (administrator)
2014-01-19 05:10

Inform now parses "The interesting collection is a description of numbers that varies." (and similar sentences) as you intend, but it remains the case that description literals aren't allowed, for now at least.

- Issue History
Date Modified Username Field Change
2012-03-19 18:39 NYKevin New Issue
2012-03-20 12:07 EmacsUser Note Added: 0001610
2012-03-20 12:07 EmacsUser Relationship added related to 0000686
2012-03-25 09:15 NYKevin Note Added: 0001619
2012-03-30 22:52 EmacsUser Reproducibility have not tried => always
2012-03-30 22:52 EmacsUser Status new => confirmed
2012-04-02 12:00 EmacsUser Relationship replaced child of 0000686
2014-01-19 05:10 graham Note Added: 0002320
2014-01-19 05:10 graham Status confirmed => resolved
2014-01-19 05:10 graham Resolution open => fixed
2014-01-19 05:10 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker