Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000885Core InformActivitiespublic2012-03-18 16:112014-05-07 07:34
ReporterNYKevin 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000885: While <activity> a thing (called X) doesn't assign to X
DescriptionIf a rule has a while condition which refers to an activity on things and tries to call the object of said activity something, the name won't be assigned.

The attached example shows "nothing" instead of "yourself".
Minimal Source Text To Reproduce
There is room.
Considering something is an activity on things.

After printing the name of something while considering a thing (called X):
	Say paragraph break;
	Showme X.
   
Before looking:
	Begin the considering activity with the player;
	If handling the considering activity with the player:
		Say "Handling it!";
		Say the player;
		Say "Handled!";
	End the considering activity with the player.
Additional InformationPlease mark as related to bug 884.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
related to 0000884closedgraham A while clause that specifies the basis of an activity compiles only for some kinds of bases 

-  Notes
(0002299)
graham (administrator)
2014-01-17 15:11

Yes, Inform just isn't able to do this, because of the way "a thing (called X)" is handled internally - it's in effect a closure. X could be created, but it would vanish again before it could be used. There's now a problem message explaining the limitation.

- Issue History
Date Modified Username Field Change
2012-03-18 16:11 NYKevin New Issue
2012-03-18 16:26 EmacsUser Relationship added related to 0000884
2012-03-18 16:26 EmacsUser Status new => confirmed
2012-03-18 16:26 EmacsUser Category Kinds and type checking => Activities
2014-01-17 15:11 graham Note Added: 0002299
2014-01-17 15:11 graham Status confirmed => resolved
2014-01-17 15:11 graham Resolution open => fixed
2014-01-17 15:11 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker