Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000877Core InformRelationspublic2012-03-05 04:322014-05-07 07:34
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000877: internal error, "binding and substitution line 364"
DescriptionThe line,

   now the attempt which is fulfilled by this attempt is untried.

Causes an internal error. I can comment out the "which is" and it still happens.
Minimal Source Text To Reproduce
"test3" by Ron Newcomb

An attempt is a kind of thing.  
An attempt can be failed, successful, ongoing, or untried. 

Fulfillment relates various attempts to one attempt. 
The verb to be fulfilled by implies the reversed fulfillment relation..

This attempt is an attempt that varies. There is an attempt.

When play begins, now the attempt which is fulfilled by this attempt is untried.

the lab is a room.
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships

-  Notes
(0001599)
EmacsUser (manager)
2012-03-05 12:28

Confirmed. The problem message, for the sake of future bug searches:

- - - -
An internal error has occurred: substituting bound variable. The current sentence is 'now the attempt which is fulfilled by foo is untried' ; the error was detected at line 364 of "Chapter 13/Binding and Substitution.w". This should never happen, and I am now halting in abject failure.
- - - -
(0002078)
graham (administrator)
2013-06-02 08:08

Fixed, though this is quite a complex issue. There was a straightforward bug due to a failure to simplify correctly in some logical calculations, and I took that out; but Inform now produces a problem message on the line about "now" not being able to change the kind of something. This looks wrong but is in fact right, because "now the attempt which is fulfilled by this attempt is untried" assumes that there is such an attempt: if there isn't, then there is no way to make it untried.

- Issue History
Date Modified Username Field Change
2012-03-05 04:32 Ron Newcomb New Issue
2012-03-05 12:28 EmacsUser Note Added: 0001599
2012-03-05 12:28 EmacsUser Status new => confirmed
2013-06-02 08:08 graham Note Added: 0002078
2013-06-02 08:08 graham Status confirmed => resolved
2013-06-02 08:08 graham Resolution open => fixed
2013-06-02 08:08 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker