Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000875Documentation, Examples, and Web SiteWriting with Informpublic2012-02-29 12:182014-05-07 07:38
Reportermattweiner 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityN/A
StatusclosedResolutionfixed 
PlatformMacintoshOSOS XOS Version10.7.2
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000875: If there is a rule for deciding the concealed possessions, all possessions default to concealed
DescriptionIf you write a rule for the deciding the concealed possessions of an NPC and omit "otherwise no" at the end, all the NPC's possessions that are not covered by the rule will be concealed.
Minimal Source Text To Reproduce
The Gym is a room.

Bob is a person in the gym. Bob carries a dumbbell. Bob carries a bottle.

Rule for deciding the concealed possessions of Bob: if the particular possession is the bottle, yes [or 
no].
 
Test me with "x dumbbell".
Additional InformationThe behavior is the same whether the rule for the bottle says "yes" or "no."

The documentation is confusing here; 17.9 says the default behavior is none of the possessions to be concealed, which of course is the behavior if no rules for deciding concealed possessions are written; but it's natural to interpret as meaning that if a rule is given but makes no ruling on a given possession, that it will not be concealed.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001597)
mattweiner (reporter)
2012-02-29 16:19

In additional information, that should be

The behavior is the same whether the rule for the bottle says "yes" or "no."
(0001598)
EmacsUser (manager)
2012-02-29 18:52

Only the most specific applicable for rule should be considered (WI 17.3, point 2), so the behavior looks right to me. But because WI 17.9 doesn't mention what happens if no decision is made, nor does WI 17.34 in regards to deciding whether all includes, I've recategorized the report as a documentation bug and confirmed.

- Issue History
Date Modified Username Field Change
2012-02-29 12:18 mattweiner New Issue
2012-02-29 16:19 mattweiner Note Added: 0001597
2012-02-29 18:49 EmacsUser Additional Information Updated View Revisions
2012-02-29 18:50 EmacsUser Project Core Inform => Documentation, Examples, and Web Site
2012-02-29 18:52 EmacsUser Note Added: 0001598
2012-02-29 18:52 EmacsUser Reproducibility have not tried => N/A
2012-02-29 18:52 EmacsUser Status new => confirmed
2012-02-29 18:52 EmacsUser Category Activities => Writing with Inform
2014-01-25 07:44 graham Status confirmed => resolved
2014-01-25 07:44 graham Resolution open => fixed
2014-01-25 07:44 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker