Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000087Core InformPhrases and functional programmingpublic2010-06-21 11:552010-07-01 23:07
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.4
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000087: There is no line number when a phrase's implicit return cannot find a default value
DescriptionThe decision phrase in the source has an implicit return for when the repeat happens zero times. That return corresponds to no text, but in a large project it would help authors to at least point to the offending phrase. Also, in this case it wouldn't hurt to give some more explanation of <no text>.

Problem. I am unable to put any value into the return value '<no text>', which needs to be a meditation, because there is no meditation in the world.
 See the manual: 4.12 > Values that vary
Minimal Source Text To Reproduce
The balcony is a room.
A meditation is a kind.
To decide what meditation is the ex nihilo meditation:
	repeat with the idea running through the meditations:
		decide on the idea.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0000131)
graham (administrator)
2010-06-22 16:32

Fixed. Inform now produces a much more helpful problem message here, and links to the declaration of the phrase, since that's where the unkeepable promise is made.

- Issue History
Date Modified Username Field Change
2010-06-21 11:55 EmacsUser New Issue
2010-06-21 17:25 jmcgrew Status new => confirmed
2010-06-22 16:32 graham Note Added: 0000131
2010-06-22 16:32 graham Status confirmed => resolved
2010-06-22 16:32 graham Resolution open => fixed
2010-06-22 16:32 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker