Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000867Core InformPhrases and functional programmingpublic2012-02-16 07:592014-05-07 07:34
ReporterFuchsia tude 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSWindowsOS Version7 SP1
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000867: Error message about a definition referencing a past-tense condition is misleading
DescriptionThe problem report claims that a past-tense condition referring to a temporary value is the problem. Thing is, there are no temporary values mentioned here.
Minimal Source Text To Reproduce
There is room. Egg is here.

Definition: Egg is contaminated if it was held.
Additional InformationThis is the report produced by Inform 7 (build 6G60) on its most recent run through:


Problem. You wrote 'Definition' : but conditions written in the past tense cannot refer to temporary values, because they have no past. For instance, the name given in a 'repeat...' can't be talked about as having existed before.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0001585)
EmacsUser (manager)
2012-02-16 09:10

In fact there is a temporary named value, ``it.'' Because Inform needs to be able to apply the definition of contaminated to other things, the attached source text is read as

- - - -
Definition: a thing is contaminated if it is the egg and it was held.
- - - -

But that's not necessarily obvious from the problem message.

- Issue History
Date Modified Username Field Change
2012-02-16 07:59 Fuchsia tude New Issue
2012-02-16 09:10 EmacsUser Note Added: 0001585
2012-02-16 09:10 EmacsUser Status new => confirmed
2012-02-16 09:10 EmacsUser Category Actions => Phrases and functional programming
2014-01-22 14:30 graham Status confirmed => resolved
2014-01-22 14:30 graham Resolution open => fixed
2014-01-22 14:30 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker