Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000864Core InformAssertions and creationspublic2012-02-12 00:052014-05-07 07:34
ReporterFuchsia tude 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSWindowsOS Version7 SP1
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000864: When including an extension after defining a room, the error message implies no room exists
DescriptionIn fact, there are multiple locations defined in the story; the issue apparently is that a subsequent extension include line clears the compiler's last-mentioned-room, leading it to assume that no room has yet been defined in the source.

Notably, defining further facts about one of the rooms after the include line allows the game to compile and proves that the world model has been constructed properly; but this must take the form "Office is dark" or "Office is north from the Secret Passage", rather than "A desk is in Office", to reestablish with the compiler the fact that the Office is a room and not a thing.

As a side note, "here doesn't seem to be any location at this point in the story" seems to be a typo, or at least a very odd phrase; replacing this initial "here" with "there" (or else bracketing it within apostrophes, as in the other instances) would make the sentence fit much more naturally within the paragraph.
Minimal Source Text To Reproduce
The Pie Factory is north from the Supervisor's Office.

Include Locksmith by Emily Short.

An apple streudel is here.
Additional InformationThis is the report produced by Inform 7 (build 6G60) on its most recent run through:


Problem. The apple streudel was described as being 'here', but here doesn't seem to be any location at this point in the story, so there's nowhere you can call 'here'.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0001586)
EmacsUser (manager)
2012-02-16 10:29

Confirmed that ``here doesn't seem to be any location at this point in the story'' could better convey that the word ``here,'' because it means the location being discussed, can't be used if no location is under discussion.

- Issue History
Date Modified Username Field Change
2012-02-12 00:05 Fuchsia tude New Issue
2012-02-16 10:29 EmacsUser Note Added: 0001586
2012-02-16 10:29 EmacsUser Status new => confirmed
2014-01-22 14:32 graham Status confirmed => resolved
2014-01-22 14:32 graham Resolution open => fixed
2014-01-22 14:32 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker