Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000862Core InformHeadingspublic2012-02-06 09:292014-05-07 07:34
ReporterChrisC 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000862: Ending a heading with punctuation causes an inaccurate error message
DescriptionThe problem isn't that the heading contains a full stop, but colons and semicolons stop the compiler as well.
Minimal Source Text To Reproduce
Chapter 1 - A Beginning:

There is room.
Additional InformationThe text 'Chapter 1 - A Beginning' seems to be a heading, but does not occupy the whole of its line of source text, which continues ':' . The rule is that a heading must occupy a whole single line which is the only sentence in its paragraph, so there must be a skipped line above and below, and it must not contain any full stop characters '.', even if they occur in an ellipsis '...' or a number '2.3.13'. (I mention this because sometimes this problem arises when a decimal point is misread as a full stop.)
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships
has duplicate 0000958closed Colons are not permitted in headings 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-02-06 09:29 ChrisC New Issue
2012-02-06 11:35 EmacsUser Status new => confirmed
2012-08-01 18:12 EmacsUser Relationship added has duplicate 0000958
2014-01-22 13:55 graham Status confirmed => resolved
2014-01-22 13:55 graham Resolution open => fixed
2014-01-22 13:55 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker