Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000860Core InformUnderstandingpublic2012-02-02 19:492014-05-07 07:33
Reportercapmikee 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionunable to reproduce 
Platformx86OSMac OS XOS Version10.5
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000860: test command causes DPMR to be skipped
DescriptionDPMR runs for "put mouth in hand" for test two but not test one. This appears to be consistent every time the test is executed, but hard to predict when entering commands one at a time outside a test.
Minimal Source Text To Reproduce
Test is a room.

Bob is a man in Test. Sue is a woman in Test.

Understand "mouth" as a person.

Does the player mean: 
	showme the current action; 
	make no decision.

test one with "put mouth in hand / put hand in mouth".
test two with "put hand in mouth / put mouth in hand".
Additional InformationFelix discovered this bug, and EmacsUser informs us that "there's a reset of cobj_flag missing somewhere."
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0001576)
EmacsUser (manager)
2012-02-03 08:23

Confirmed, though to be clear I only suspect cobj_flag—I'm not actually sure that's the issue.
(0002505)
graham (administrator)
2014-02-15 06:12

I suspect this was fixed as a result of something else being fixed; it doesn't happen now.

- Issue History
Date Modified Username Field Change
2012-02-02 19:49 capmikee New Issue
2012-02-03 08:23 EmacsUser Note Added: 0001576
2012-02-03 08:23 EmacsUser Status new => confirmed
2014-02-15 06:12 graham Note Added: 0002505
2014-02-15 06:12 graham Status confirmed => resolved
2014-02-15 06:12 graham Resolution open => unable to reproduce
2014-02-15 06:12 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker