Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000838Core InformKinds and type checkingpublic2012-01-13 15:452014-05-07 07:34
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000838: Global variables cannot be declared to hold rulebook outcomes
DescriptionThe attached source leads to

- - - -
Problem. I am unable to put any value into the variable 'Foo', because rulebook outcome is a kind of value with no actual values.
- - - -

which would seem to contradict the output of a story like

- - - -
There is a room.
When play begins:
    showme the there is sufficient light outcome.
- - - -
Minimal Source Text To Reproduce
There is a room.
Foo is a rulebook outcome that varies.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships
related to 0000839closedgraham The kinds ``rulebook outcome'' and "topic" do not appear in the kinds tab of the index 

-  Notes
(0001689)
curiousdannii (developer)
2012-06-20 08:23

This compiles too, so it is only a problem for global variables.

There is a room.
When play begins:
    let a be the there is sufficient light outcome;
    showme a.
(0002292)
graham (administrator)
2014-01-14 13:14

While I never intended people to make variables of this kind, which exists for internal reasons, I agree that it's an unnecessary inconsistency to behave as the example source does. I've enabled this.

- Issue History
Date Modified Username Field Change
2012-01-13 15:45 EmacsUser New Issue
2012-01-13 15:48 EmacsUser Issue cloned 0000839
2012-01-13 15:48 EmacsUser Relationship added related to 0000839
2012-06-20 08:23 curiousdannii Note Added: 0001689
2012-06-20 08:23 curiousdannii Status new => confirmed
2012-06-20 08:23 curiousdannii Description Updated View Revisions
2014-01-14 13:14 graham Note Added: 0002292
2014-01-14 13:14 graham Status confirmed => resolved
2014-01-14 13:14 graham Resolution open => fixed
2014-01-14 13:14 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker