Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000826Core InformIndexingpublic2011-12-23 08:192014-05-07 07:33
ReporterDavidK 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000826: The index's Contents page can grow so large that Inform 7 crashes
DescriptionThe Contents page generated by NI as part of the index contains an entry for each picture included in a project, including a reference to the picture itself, which is included at a reduced size.

A user has sent me a project that causes Inform 7 to fail with "out of memory" errors. The underlying problem is that the project contains 1,940 pictures, varying between 15Kb and 420Kb. Since the HTML page for the contents contains references to every one of these, the HTML control (part of IE) used by Windows Inform 7 uses up all available memory in the process space while trying to show the page. This doesn't seem to be limited to being an IE-based problem: if the same page is opened in Firefox then Firefox crashes.

It would seem sensible to have a limit on the number of pictures shown in the "List of figures" section of the contents - say 100. Alternatively, perhaps there should be a way to set a limit from the game's source code.
TagsNo tags attached.
Effect(cosmetic) Index is created incorrectly
Attached Files

- Relationships

-  Notes
(0002365)
graham (administrator)
2014-01-25 13:31

The Contents index page now displays thumbnails only for the first 50 figures by default, but Inform provides the use option "Use index figure thumbnails of at least X." to raise this as needed.

- Issue History
Date Modified Username Field Change
2011-12-23 08:19 DavidK New Issue
2012-01-02 09:36 EmacsUser Status new => confirmed
2014-01-25 13:31 graham Note Added: 0002365
2014-01-25 13:31 graham Status confirmed => resolved
2014-01-25 13:31 graham Resolution open => fixed
2014-01-25 13:31 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker