Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000825Core InformPhrases and functional programmingpublic2011-12-21 13:392014-05-07 07:34
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000825: Within one phrase, only the first occurrence of a particular dynamic dispatch is compiled to a resolver
DescriptionThe identical invocations in the attached source produce different I6; the latter case bypasses the resolver routine.
Minimal Source Text To Reproduce
There is a room.
To dispatch based on (X - a thing): say "Fail."
To dispatch based on (X - a thing that is yourself): say "Pass."
When play begins:
	dispatch based on yourself;
	dispatch based on yourself.
Additional Information! When play begins:
[ R_742 ;
  ! phrase 1
  ! [1: dispatch based on yourself]
  (Resolver_0(selfobj,"source", 16));
  ! phrase 2
  ! [2: dispatch based on yourself]
  (PHR_740_r4 (selfobj));
 rfalse;
];
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0002317)
graham (administrator)
2014-01-19 03:26

An important one to fix. There are no Resolver routines any more (dynamic dispatch is done inline instead), but the underlying fault was still there; it was to do with a substitution made to the logical proposition "a thing that is yourself" the first time the call is made, which was intended to be temporary, but which instead persisted and changed the reading of the phrase on subsequent calls.

- Issue History
Date Modified Username Field Change
2011-12-21 13:39 EmacsUser New Issue
2011-12-21 13:39 EmacsUser Reproducibility sometimes => always
2011-12-21 13:39 EmacsUser Additional Information Updated View Revisions
2012-03-31 20:48 jmcgrew Status new => confirmed
2014-01-19 03:26 graham Note Added: 0002317
2014-01-19 03:26 graham Status confirmed => resolved
2014-01-19 03:26 graham Resolution open => fixed
2014-01-19 03:26 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker