Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000820Core InformKinds and type checkingpublic2011-12-16 12:252014-05-07 07:33
Assigned Tograham 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000820: <no text> in problem message provoked by undefined kind variable
DescriptionIf the return kind of a phrase is given by a kind variable that the author forgot to define, one of the problem messages reads ``I am unable to create '<no text>' with...'', as in the attached source:

- - - -
Problem. You wrote 'decide on ""' as the outcome of a phrase to decide a value, but this was the wrong kind of value: a text rather than an L.
 See the manual: 11.17 > Phrases to decide other things
Problem. I am unable to create '<no text>' with the kind of value 'an L', because this is a kind of value which is not allowed as something to be stored in properties, variables and the like. (See the Kinds index for which kinds of value are available. The ones which aren't available are really for internal use by Inform.)
Problem. You wrote 'To decide what L is foo' : but but it's not possible to decide such a value, so this can't be allowed.
- - - -
Minimal Source Text To Reproduce
There is a room.
To decide what L is foo:
	decide on "".
When play begins:
	showme foo.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-12-16 12:25 EmacsUser New Issue
2012-06-20 08:42 curiousdannii Status new => confirmed
2014-01-22 16:41 graham Status confirmed => resolved
2014-01-22 16:41 graham Resolution open => fixed
2014-01-22 16:41 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker