Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000801Core InformKinds and type checkingpublic2011-11-08 15:032014-05-07 07:33
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000801: deep copy fails when rvalue is indexed text variable, not literal
DescriptionI'm unsure if this is a bug, but the runtime problem only appears when used with the variable, not with the literal. That's doubly odd because the literal would likely be text -- not indexed -- and need casting while the ready-to-go variable throws an error about the *lvalue*?
Minimal Source Text To Reproduce
Paul, John, Ringo, and George are men.

Table of NPC Activity
who	activity
person	indexed text
Paul 	--
John	--
Ringo	--
George	--

when play begins:
	let whoIsIt be a random man;
	let tempActivity be indexed text;
	now tempActivity is "goes ";
	now the activity corresponding to a who of whoIsIt in the Table of NPC Activity is tempActivity;
	
there is room
Additional InformationChanging the line to:

    now the activity corresponding to a who of whoIsIt in the Table of NPC Activity is "goes [random direction]";

... does not throw the error.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0001455)
EmacsUser (manager)
2011-11-11 10:46
edited on: 2011-11-11 14:01

Confirmed one part of the bug: a write flag is being passed to TableLookUpCorr but not a write value because a BlkValueCopy or BlkValueCast is being generated instead. So TableLookUpCorr returns false, which is equal to a zero pointer; the copy fails, and the cast allocates a new indexed text that is subsequently leaked. Possibly related to 0000366. But something else is going on too...which I've now reported as 0000802.

And apologies for all of the spam I've made by editing this comment.


- Issue History
Date Modified Username Field Change
2011-11-08 15:03 Ron Newcomb New Issue
2011-11-11 10:46 EmacsUser Note Added: 0001455
2011-11-11 10:46 EmacsUser Status new => confirmed
2011-11-11 12:21 EmacsUser Note Edited: 0001455 View Revisions
2011-11-11 13:57 EmacsUser Note Edited: 0001455 View Revisions
2011-11-11 13:58 EmacsUser Note Edited: 0001455 View Revisions
2011-11-11 14:01 EmacsUser Note Edited: 0001455 View Revisions
2011-12-13 20:35 EmacsUser Relationship added related to 0000802
2011-12-13 20:35 EmacsUser Relationship deleted related to 0000802
2014-02-01 07:21 graham Status confirmed => resolved
2014-02-01 07:21 graham Resolution open => fixed
2014-02-01 07:21 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker