Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000789Documentation, Examples, and Web SiteWriting with Informpublic2011-10-31 11:022014-05-07 07:38
Assigned Tograham 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000789: The documentation is wrong about the "deciding the scope of" activity.
DescriptionChapter 17.27 (Deciding the scope of something) claims that placing a room in scope only puts the contents of the room in scope, not the room itself. That's not true. (You'd have to say "place the contents of the Ballroom in scope" to get that effect.)

Here's the quote:

'When a room is placed in scope, this is understood as placing its contents in scope rather than the room-object itself. So "place the Ballroom in scope" allows the player to talk about the dancers, the chamber musicians and so forth, but not to "EXAMINE BALLROOM" as such. (This is sensible because actions like examining apply to things: and a room, unlike a container or a supporter, is not a kind of thing.)'
Minimal Source Text To Reproduce
The Ballroom is a room. 
After deciding the scope of the player: place the Ballroom in scope.
Test me with "x ballroom / get ballroom".
Additional InformationBallroom

>x ballroom
You see nothing special about the Ballroom.

>get ballroom
You'd have to get out of the Ballroom first.

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
gnomon (reporter)
2011-10-31 11:05

Maybe this isn't actually an error in the manual but a bug in Inform?
zarf (developer)
2011-11-04 23:13

You can say "place the Ballroom in scope", "place the contents of the Ballroom in scope", or "place the Ballroom in scope, but not its contents". This is straightforward and implies that the behavior you see is correct, so the documentation is wrong.
gnomon (reporter)
2011-11-05 07:29

Yeah, I found the version where this was changed (5T18), seems like they just missed this bit when updating the docs.

- Issue History
Date Modified Username Field Change
2011-10-31 11:02 gnomon New Issue
2011-10-31 11:05 gnomon Note Added: 0001432
2011-11-01 10:04 EmacsUser Status new => confirmed
2011-11-04 23:13 zarf Note Added: 0001448
2011-11-05 07:29 gnomon Note Added: 0001449
2014-01-25 07:31 graham Status confirmed => resolved
2014-01-25 07:31 graham Resolution open => fixed
2014-01-25 07:31 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker