Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000788Core InformModel worldpublic2011-10-31 10:502014-05-07 07:33
Assigned Tograham 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000788: The carrying capacity is ignored when giving.
DescriptionThe giving it to action doesn't check the carrying capacity of the recipient before transfering the object.
Minimal Source Text To Reproduce
The Kitchen is a room. An onion is here. 
The carrying capacity of a person is usually 1.
Phil is a man in the Kitchen. The player carries a knife.

The block giving rule is not listed in the check giving it to rules.
A persuasion rule: persuasion succeeds.

Test me with "get onion / Phil, get onion / Phil, give me the onion / i".
Additional InformationKitchen
You can see an onion and Phil here.

>get onion
You're carrying too many things already.

>Phil, get onion
Phil picks up the onion.

>Phil, give me the onion
Phil gives the onion to you.

You are carrying:
  an onion
  a knife

TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
gnomon (reporter)
2011-10-31 10:53

Of course, since giving is blocked by default, technically this can't happen unless you change the rules, but the manual implies that giving is fully implemented: all you have to do is disable the block giving rule*.

To complete the action, perhaps there should be a rule that does something like this:

Check an actor giving something to (this is the can’t exceed carrying capacity when giving rule):
   if the number of things carried by the second noun is at least the carrying capacity of the second noun:
      if the actor is the player, say "[The second noun] [if the second noun is plural-named]are[otherwise]is[end if] carrying too many things already.";
      stop the action.

Ex. 207: "However, suppose that we do want characters to be able to exchange articles freely: we allow persuasion to succeed and turn off the "block giving rule"."

Ex. 378: "As it happens, correct behavior is built into the GIVE command once "block giving" is turned off"
graham (administrator)
2014-02-15 02:46

I concur, and have added the "can't exceed carrying capacity when giving rule".

- Issue History
Date Modified Username Field Change
2011-10-31 10:50 gnomon New Issue
2011-10-31 10:53 gnomon Note Added: 0001431
2011-11-02 13:15 EmacsUser Status new => confirmed
2011-11-02 13:15 EmacsUser Category Actions => Model world
2014-02-15 02:46 graham Note Added: 0002499
2014-02-15 02:46 graham Status confirmed => resolved
2014-02-15 02:46 graham Resolution open => fixed
2014-02-15 02:46 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker