Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000781Core InformExtensionspublic2011-10-20 15:012014-05-07 07:33
Assigned Tograham 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000781: Author name of extension does not permit non-UTF-8 characters
DescriptionWhen installing an extension whose author's name contains non-UTF-8 characters (such as å, ä, ö, ü, ÿ), the Inform 7 IDE cannot display the extension's documentation page due to the folder path being mangled.
Minimal Source Text To Reproduce
Dummy Extension by Björn Paulsen begins here.

A thing can be inline-marked.

Dummy Extension ends here.


A dummy extension.
Effect(cosmetic) Index is created incorrectly
Attached Files

- Relationships

-  Notes
DavidK (developer)
2011-10-22 13:48

This is a problem in the core NI compiler, so I've moved it from a Windows front-end error to here. The problem is that when NI generates a HTML page that links to the extension, the link contains


where X is the character with hex code F6. In ISO-Latin-1 that is the o-with-umlaut, but all the generated HTML pages (correctly) have a character set of UTF-8, and that and Latin-1 only overlap for the first 128 characters...

Whenever links are generated, this will need to be worried about.
graham (administrator)
2014-01-26 15:24

Fiddly as all get-out, but I believe this is now done.

- Issue History
Date Modified Username Field Change
2011-10-20 15:01 Eleas New Issue
2011-10-22 13:44 DavidK Project Windows Inform application => Core Inform
2011-10-22 13:45 DavidK Effect => (cosmetic) Index is created incorrectly
2011-10-22 13:45 DavidK Category Installing Extensions => Actions
2011-10-22 13:48 DavidK Note Added: 0001427
2011-10-22 14:45 EmacsUser Status new => confirmed
2011-10-22 14:45 EmacsUser Category Actions => Extensions
2011-10-22 14:46 EmacsUser Tag Attached: wrongeffect
2014-01-26 15:24 graham Note Added: 0002389
2014-01-26 15:24 graham Status confirmed => resolved
2014-01-26 15:24 graham Resolution open => fixed
2014-01-26 15:24 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker