Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000760Core InformActivitiespublic2011-09-28 19:462014-05-07 07:34
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000760: Type mis-match in Parser.i6t
DescriptionParser.i6t includes this line:

FollowRulebook(Activity_after_rulebooks-->READING_A_COMMAND_ACT, true);

But there's little point in setting the I7 parameter-object to a truth state, especially because the variable usually has leftover junk values in it when that activity is normally called. I believe the line should read either:

FollowRulebook(Activity_after_rulebooks-->READING_A_COMMAND_ACT, nothing, true);

or

FollowRulebook(Activity_after_rulebooks-->READING_A_COMMAND_ACT);

because the definition of Follow in the Standard Rules passes a hidden third parameter to suppress paragraph breaking when the I7 source gives two parameters. Of course, the code has been allowing paragraph breaks all this time so far with little problem, so perhaps leaving the extra parameters off is fine.

Tagswrongeffect
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0001351)
graham (administrator)
2011-10-13 13:27

Harmless, but fixed, for the sake of clarity.

- Issue History
Date Modified Username Field Change
2011-09-28 19:46 Ron Newcomb New Issue
2011-09-29 14:29 EmacsUser Tag Attached: wrongeffect
2011-09-29 14:32 EmacsUser Effect (mild) Compiler accepts invalid code => (cosmetic) Error message is badly worded
2011-09-29 14:32 EmacsUser Severity mild => cosmetic
2011-09-29 14:32 EmacsUser Status new => confirmed
2011-10-13 13:27 graham Note Added: 0001351
2011-10-13 13:27 graham Status confirmed => resolved
2011-10-13 13:27 graham Resolution open => fixed
2011-10-13 13:27 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker