Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000756Core InformGlulx issues (files, figures, sounds)public2011-09-21 20:152014-05-07 07:33
Reporterzarf 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000756: "Player consents" does not update the status line under Glulx
DescriptionIf something happens that should affect the status line (such as moving the player), and then "if player consents" is invoked, the status line is out of date during the yes-or-no prompt.

The Z-code branch of YesOrNo() invokes DrawStatusLine (as long as the player has a location -- this is probably a guard against beginning-of-play questions). The Glulx branch fails to do this, so the status line stays unchanged. (Note that you can force a status line redraw by resizing the window.)

(I'm forking this off of http://inform7.com/mantis/view.php?id=752 [^] because I'm pushy, and because it was probably my mistake way back when I did the Glulx I6 libraries.)
Minimal Source Text To Reproduce
The Kitchen is a room.
The Bathroom is west of the Kitchen.

Instead of jumping:
	now the player is in the Bathroom;
	say "Do you like that? ";
	if the player consents:
		say "Yes."
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0001293)
EmacsUser (manager)
2011-09-22 11:36

Confirmed. Sorry, I probably should have split this off myself.
(0002366)
graham (administrator)
2014-01-25 13:37

It now updates on both platforms.

- Issue History
Date Modified Username Field Change
2011-09-21 20:15 zarf New Issue
2011-09-22 11:36 EmacsUser Note Added: 0001293
2011-09-22 11:36 EmacsUser Status new => confirmed
2014-01-25 13:37 graham Note Added: 0002366
2014-01-25 13:37 graham Status confirmed => resolved
2014-01-25 13:37 graham Resolution open => fixed
2014-01-25 13:37 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker