Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000755Documentation, Examples, and Web SiteInform7.com Sitepublic2011-09-21 14:572014-05-07 07:38
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000755: Appendix B's description of MoveWord() implies incorrect parameter type
DescriptionAppendix B states (using square brackets to denote mono-spaced text):

        [MoveWord(at1, b2, at2)] copies word at2 from parse buffer b2 – which doesn’t need to be [buffer] – to word at1 in parse.

I believe that "[buffer]" should be "[parse]", like this:

        [MoveWord(at1, b2, at2)] copies word at2 from parse buffer b2 – which doesn’t need to be [parse] – to word at1 in parse.

The "buffer" arrays are indeed ZSCII-based as the earlier text describes, but this function works on the "parse" arrays, which are struct-based.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001285)
Ron Newcomb (reporter)
2011-09-21 14:59

I also cannot see anywhere where MoveWord() is actually used, either in Appendix B, Appendix A, or a compiled game. Perhaps some weird I7 Topic's generated code needs it?
(0001291)
EmacsUser (manager)
2011-09-21 17:14

Confirmed. MoveWord does seem to be dead code.
(0001362)
graham (administrator)
2011-10-15 01:24

I concur. MoveWord isn't used, and since it does something inherently unfortunate, I've removed it altogether.

- Issue History
Date Modified Username Field Change
2011-09-21 14:57 Ron Newcomb New Issue
2011-09-21 14:59 Ron Newcomb Note Added: 0001285
2011-09-21 17:14 EmacsUser Note Added: 0001291
2011-09-21 17:14 EmacsUser Severity mild => cosmetic
2011-09-21 17:14 EmacsUser Status new => confirmed
2011-10-15 01:24 graham Note Added: 0001362
2011-10-15 01:24 graham Status confirmed => resolved
2011-10-15 01:24 graham Resolution open => fixed
2011-10-15 01:24 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker