Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000750Core InformKinds and type checkingpublic2011-09-16 08:112014-05-07 07:34
ReporterRon Newcomb 
Assigned Tograham 
PlatformPPCOSMac OS XOS Version10.4
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000750: Error message does not mention the basis for a rule when that basis causes a type mismatch
DescriptionIf I have phrase expecting a "rule producing a truth state" and a variable that's a "nothing based rule producing a truth state", Inform throws a problem message:

             'box' has the wrong kind of value: a rule producing truth states rather than a rule producing truth states.

It also does this in reverse -- if the variable has the "nothing based" label but the phrase's parameter type lacks it.
Minimal Source Text To Reproduce
"bug" by Ron Newcomb. There is a room. 

To decide if (ph - a  rule producing a truth state) is ok:
        say "Yes".

The box is a nothing based rule producing a truth state that varies. 

When play begins, if the box is ok, say "The box is ok."

Additional InformationThe phrase's parameter is implicitly action-based, but the error message does not mention that fact.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
graham (administrator)
2011-10-15 04:11

This is a tricky area - Inform doesn't spell out all kinds in full because the result would be pretty tiresome, but clearly it makes this (correctly issued) problem message a nonsense. Fixed.

- Issue History
Date Modified Username Field Change
2011-09-16 08:11 Ron Newcomb New Issue
2011-09-16 09:32 EmacsUser Note Added: 0001274
2011-09-16 09:32 EmacsUser Status new => confirmed
2011-09-16 09:32 EmacsUser Relationship added related to 0000473
2011-09-16 09:32 EmacsUser Note Deleted: 0001274
2011-09-16 09:32 EmacsUser Relationship deleted related to 0000473
2011-09-16 09:37 EmacsUser Effect (serious) Compiler rejects valid code => (cosmetic) Error message is badly worded
2011-09-16 09:37 EmacsUser Severity mild => cosmetic
2011-09-16 09:37 EmacsUser Summary a "nothing based rule producing truth states" doesn't typecheck with "rule producing truth states" => Error message does not mention the basis for a rule when that basis causes a type mismatch
2011-09-16 09:37 EmacsUser Additional Information Updated View Revisions
2011-10-15 04:11 graham Note Added: 0001370
2011-10-15 04:11 graham Status confirmed => resolved
2011-10-15 04:11 graham Resolution open => fixed
2011-10-15 04:11 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker