Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000748Documentation, Examples, and Web SiteWriting with Informpublic2011-09-15 05:122014-05-07 07:38
ReporterRon Newcomb 
Assigned Tograham 
PlatformPPCOSMac OS XOS Version10.4
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000748: 25.18. "Longer extracts of Inform 6 code" warns of a problem that was already fixed?
DescriptionThe bottom of 25.18. "Longer extracts of Inform 6 code" says not to put @opcodes against the left margin, but this was fixed a long time ago, wasn't it? I reported that bug myself (pre-Mantis) and coulda swore I got an email from Graham stating it fixed.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
zarf (developer)
2011-09-19 08:47

The @glk opcode (Glulx-only, of course) takes three operands. (Function ID, number of arguments to pull from the stack, return value.) Call 67 (glk_stream_open_memory) takes four arguments, so this would look like "@glk 67 4 ret;" -- after pushing four values onto the stack.
Ron Newcomb (reporter)
2011-09-19 10:17
edited on: 2011-09-19 10:17

I was compiling on Z, of course. Doh. This @op-on-left-margin bug still exists and the documentation is correct to warn of it, my bad.

EmacsUser (manager)
2011-09-21 16:47

Ron, do you have an example where a valid opcode in column one causes trouble? I can't replicate the problem that WI warns about without resorting to @p or @c or the like.
Ron Newcomb (reporter)
2011-09-22 02:34

Hm, I do not. As originally stated I believe this was fixed quite some time ago.

I apparently need to get more sleep before visiting Mantis.
EmacsUser (manager)
2011-09-22 11:44

No worries. We'll see what Graham says.
Ron Newcomb (reporter)
2011-09-22 13:17

ah, tell him to check his email from December 31, 2009:
"[I7] spurious error when an @opcode is against left margin in i6t replacement"

Fixed. The change log reads:

The I6 template reader has been made more forgiving of what it considers
malformed headings - marked by the use of an "@" character in the leftmost
column; some users ran into this by accidentally placing Z-machine or Glulx
assembly language, also marked by an "@" in I6, unindented on the left
margin of material included using "(-" and "-)". The template reader will
now handle any such material correctly, and a more helpful problem message
is produced if it nevertheless runs into trouble because of a stray "@".
graham (administrator)
2011-10-18 14:01

The restriction exists, but is now more politely dealt with than in 6G60, where it produced an explanatory but still internal error:

Problem. An unknown '@...' marker has been found at column 0 in raw Inform 6 template material: specifically, '@fish;'. ('@' has a special meaning in this first column, and this might clash with its use to introduce an assembly-language opcode in Inform 6: if that's a problem, you can avoid it simply by putting one or more spaces or tabs in front of the opcode(s) to keep them clear of the left margin.)

The documentation warning is sensibly worded as it stands, I think.

- Issue History
Date Modified Username Field Change
2011-09-15 05:12 Ron Newcomb New Issue
2011-09-19 08:47 zarf Note Added: 0001275
2011-09-19 10:17 Ron Newcomb Note Added: 0001276
2011-09-19 10:17 Ron Newcomb Note Edited: 0001276 View Revisions
2011-09-21 16:47 EmacsUser Note Added: 0001288
2011-09-22 02:34 Ron Newcomb Note Added: 0001292
2011-09-22 11:44 EmacsUser Note Added: 0001294
2011-09-22 11:44 EmacsUser Description Updated View Revisions
2011-09-22 11:44 EmacsUser Status new => confirmed
2011-09-22 13:17 Ron Newcomb Note Added: 0001296
2011-10-18 14:01 graham Note Added: 0001416
2011-10-18 14:01 graham Status confirmed => resolved
2011-10-18 14:01 graham Resolution open => fixed
2011-10-18 14:01 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker