Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000746Core InformReleasing, bibliographic data, cBlorbpublic2011-09-13 23:552014-05-07 07:33
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000746: "Release number" and "story headline" et al not set according to 23.2. Bibliographic data
DescriptionThe bottom of 23.2 "Bibliographic data" says these are the defaults:

Story title: Untitled
Story author: Anonymous
Story headline: An Interactive Fiction
Story genre: Fiction
Release number: 1

The in-game variables don't reflect this if unset, but some of them could and save memory to boot. Add these lines to the Standard Rules, Section SR2/6a "Unindexed Standard Rules", right after <<The story title variable translates into I6 as "Story".>>

        The story headline variable translates into I6 as "Headline".
        The release number is usually 1.

Because of the "usually", these still allow an author to set the variables directly. (I tested them both.) And since the story headline is pointed to the pre-existing I6 variable, it reduces memory usage.

Furthermore, we could almost do this:

       The story author variable translates into I6 as "Story_Author".

Except that I6 variable isn't always created by the I7 compiler. But, the Standard Rules *always* creates "the story author" as Global_Vars-->2, which seems odd. If there's no author, Global_Vars-->2 will exist but be blank, but if there is an author, it will be included in the I6 twice.

Minimal Source Text To Reproduce
There is a room.

When play begins, say "My release is [release number] and the headline is '[story headline]', just 
like the below banner text says."

TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0002538)
graham (administrator)
2014-03-09 03:59

23.2 doesn't quite say this: it says these are the values used in the bibliographic data if nothing is specified. Inform distinguishes between the case when an author explicitly signs the work "Anonymous", and when the work is simply unsigned, even though both come out as "Anonymous" in the metadata. Nevertheless, I've added

The release number is usually 1.
The story headline is usually "An Interactive Fiction".
The story genre is usually "Fiction".

to the Standard Rules: but not for "story title" or "story author".

- Issue History
Date Modified Username Field Change
2011-09-13 23:55 Ron Newcomb New Issue
2011-09-16 09:29 EmacsUser Status new => confirmed
2014-03-09 03:59 graham Note Added: 0002538
2014-03-09 03:59 graham Status confirmed => resolved
2014-03-09 03:59 graham Resolution open => fixed
2014-03-09 03:59 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker