Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000727Core InformPropertiespublic2011-08-20 12:552014-05-07 07:34
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000727: Internal error storing a relation-valued property in a local
DescriptionThe attached source provokes

- - - -
Problem. An internal error has occurred: -allocate-storage-for applied to word value. The current sentence is 'let foo be bar'; the error was detected at line 1867 of "Chapter 22/Compile Invocations.w".
- - - -
Minimal Source Text To Reproduce
There is a room.
An thing has a relation of things to numbers called bar.
When play begins:
	let foo be bar.
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships
has duplicate 0000790closed "entry 1 of the list of" leads to internal error during compilation 
has duplicate 0000938closed Internal error "-allocate-storage-for applied to word value" during compilation of ordinary list-access code 
has duplicate 0000954closed Damage Dealt with a Weapon 

-  Notes
(0001344)
graham (administrator)
2011-10-09 08:19

Fixed, though, again, using properties of things abstractly as values is tricky, since a property name refers to the value of that property for the thing under discussion.

- Issue History
Date Modified Username Field Change
2011-08-20 12:55 EmacsUser New Issue
2011-10-09 08:19 graham Note Added: 0001344
2011-10-09 08:20 graham Status new => resolved
2011-10-09 08:20 graham Resolution open => fixed
2011-10-09 08:20 graham Assigned To => graham
2011-11-01 09:34 EmacsUser Relationship added has duplicate 0000790
2012-06-28 02:34 EmacsUser Relationship added has duplicate 0000938
2012-07-26 19:56 EmacsUser Relationship added has duplicate 0000954
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker