Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000723Core InformPhrases and functional programmingpublic2011-08-18 08:362014-05-07 07:33
ReporterJuhana 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000723: "Resume the story" doesn't work when invoked from a final question
DescriptionThe phrase "resume the story" doesn't actually resume the story when invoked after the story has effectively ended. It looks like it will only work if it's used when the deadflag has been set but the obituary hasn't been printed yet (as in example 138).

The manual (ch. 9.4.) is rather vague about this, so if this is by design maybe there should be a clarification that it's too late to use the phrase in the final options.
Minimal Source Text To Reproduce
There is a room.

Instead of jumping:
	end the story.

Table of Final Question Options (continued)
final question wording	only if victorious	topic	final response rule	final response activity   
"RESUME"	false	"resume"	resume rule	--   

This is the resume rule:
	resume the story.	

Test me with "jump/resume".
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0002478)
graham (administrator)
2014-02-11 15:22

This ought to be legal, I guess, and it now works.

- Issue History
Date Modified Username Field Change
2011-08-18 08:36 Juhana New Issue
2011-09-21 16:58 EmacsUser Status new => confirmed
2014-02-11 15:22 graham Note Added: 0002478
2014-02-11 15:22 graham Status confirmed => resolved
2014-02-11 15:22 graham Resolution open => fixed
2014-02-11 15:22 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker