Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000720Documentation, Examples, and Web SiteExamplespublic2011-08-16 08:202014-05-07 07:38
ReporterFuchsia tude 
Assigned Toemshort 
Platformx86OSWindowsOS VersionXP
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000720: Lanista 2 causes run-time error upon player death
DescriptionThe standard attacking it with a weapon rule always removes the noun from play, even if the noun is the player.
Minimal Source Text To Reproduce
The line

	if the noun is dead, remove the noun from play.

should be amended to

	if the noun is dead and the noun is not the player, remove the noun from play.

The example game functions as intended after this.
Additional Information>z
Time passes.

*** Run-time problem P43: Attempt to remove the player from play.

The gladiator attacks you with the trident, finishing you off!
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-08-16 08:20 Fuchsia tude New Issue
2011-08-19 15:16 EmacsUser Status new => confirmed
2011-10-18 11:40 graham Assigned To => emshort
2011-10-18 11:40 graham Status confirmed => assigned
2014-01-25 09:57 graham Status assigned => resolved
2014-01-25 09:57 graham Resolution open => fixed
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker