Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000719Core InformUnderstandingpublic2011-08-15 18:202014-05-07 07:34
Reportermattweiner 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.5
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000719: Using "reversed wearing" relation in an understand statement causes the game to hang on two-word commands
DescriptionWhen the following game is run, commands with no nouns (such as "sing," "jump," "look," "inventory") behave as they should, but "x me" will cause the game to hang; as will parser errors such as "x thng." "North" works but "go north" hangs. (I have only tried running the program in the IDE.)
Minimal Source Text To Reproduce
Starter is a room.
Understand "[something related by reversed wearing]" as a thing.
Additional InformationThis problem does not arise when enclosure, carrying, possession, or incorporation are substituted for wearing. It seems to be specific to wearing.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0001245)
EmacsUser (manager)
2011-08-16 18:42

Confirmed. It looks like ni is generating continues without an enclosing objloop. One workaround is a synonym relation:

- - - -
There is a room.
The player wears a tie.

Sporting relates a thing (called X) to a thing (called Y) when X wears Y.
The verb to sport (he sports, they sport, he sported, it is sported, he is sporting) implies the sporting relation.
Understand "[something related by reversed sporting]" as a thing.

Test me with "x me".
- - - -
(0002306)
graham (administrator)
2014-01-18 09:38

In fact the bug occurred for reverse carrying too, but the circumstances to trigger it were harder to bring about. Anyway, fixed.

- Issue History
Date Modified Username Field Change
2011-08-15 18:20 mattweiner New Issue
2011-08-16 18:42 EmacsUser Note Added: 0001245
2011-08-16 18:42 EmacsUser Status new => confirmed
2014-01-18 09:38 graham Note Added: 0002306
2014-01-18 09:38 graham Status confirmed => resolved
2014-01-18 09:38 graham Resolution open => fixed
2014-01-18 09:38 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker