Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000071Core InformRules and rulebookspublic2010-06-19 05:342010-07-01 23:07
Reporterfundin 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000071: Phrases to invoke value-producing rulebooks don't work with certain kinds of values
DescriptionBoth parts produce a problem message. The first reads like so:

Problem. You wrote 'let L be the list of numbers produced by the
tabulating rulebook', which I tried to match against several
possible phrase definitions. None of them worked.

[Snip the rest.]

The problem message for Part 2 is a little different:

Problem. You wrote 'let N be the number produced by the summing
rulebook for {1, 2, 3}' : but the ingredients in this phrase do not
fit it, but I am confused enough by this that I can't give a very
helpful problem message. Sorry about that.
Minimal Source Text To Reproduce
Home is a room.

Part 1

Tabulating is a rulebook producing a list of numbers.

When play begins: let L be the list of numbers produced by the
tabulating rulebook.

Part 2

Summing is a list of numbers based rulebook producing a number.

When play begins: let N be the number produced by the summing
rulebook for {1, 2, 3}.
Additional InformationThe first problem (which concerns the rulebook output) seems to
be specific to lists, but the second problem (which concerns the
input) occurs with other kinds of values as well.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships
related to 0000072closedgraham Block-type values produced by rulebooks are not handled correctly 

-  Notes
(0000079)
graham (administrator)
2010-06-20 08:30

Two independent bugs, both fixed. The first was due to an ambiguity between "list of K" as a kind name and "list of (description)" as a phrase evaluating to a value; the second was because X produced by Y for Z had been defined with the wrong prototype.

- Issue History
Date Modified Username Field Change
2010-06-19 05:34 fundin New Issue
2010-06-19 10:50 jmcgrew Status new => acknowledged
2010-06-19 13:10 jmcgrew Status acknowledged => confirmed
2010-06-19 13:29 jmcgrew Relationship added related to 0000072
2010-06-19 13:34 jmcgrew Summary Value-producing rulebooks don't work with certain kinds of values => Phrases to invoke value-producing rulebooks don't work with certain kinds of values
2010-06-20 08:30 graham Note Added: 0000079
2010-06-20 08:30 graham Status confirmed => resolved
2010-06-20 08:30 graham Resolution open => fixed
2010-06-20 08:30 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker